Final Straw! Have you ever had to stop playing a game you like (or don't) bc of technical bs? (Now under correct topic!)

  • I put this in the wrong section first time around...

    Hey allies, have you ever tried to play a game or gotten most of the way through a game only to have something happen and it makes you never want to play again? This just happened for me with Fallout 4. I got the Nuka World expansion and had been playing pretty steadily since it came out. I had finished every area of the park except the Galactic Zone and had completed exploring most of the side stuff as well. All told it was a pretty big time commitment. So I loaded up the game, for what I thought would be my final session before finishing the expansion. Well I hit load game without a second thought and when the game popped up, I was at a save that was from several real world days ago, instead of the one I made when I stopped playing only a few hours before. I thought "hmm, weird," and went to the main menu. I thought maybe I just clicked the wrong thing. BUT NOPE! The last few sessions of play were just gone. Nada, zip, nothing. The game had totally erased my entire progress through the expansion. I couldn't believe it, it really sucks to have so many hours of stuff just deleted and it zapped any motivation I had to play the game. I may have even stuck it out if the EXACT SAME THING hadn't happened a few days into the last DLC Far Harbor as well! Now that's some bullshit. On two separate occassions this game has deleted several days of playing. BGS used to be my favorite studio, but with the Action heavy RPG-lite FO4 and these progress destroying bugs, I am pretty over them. I still like fallout 4, and 3 and TES Oblivion will always be faves, but they realy seem to have let the industry catch up to them, instead of pushing the envelope for what open world RPGs can be.

    So has anyone here ever been really into a game but something technical or otherwise just ruins the game for you?

  • Pretty much every Elder Scrolls/Fallout game, it's just expected that whatever Bethesda makes isn't worth playing for several months, if ever. Some bugs they just never bother fixing.

    Worse if you're playing on console since the engine they use carries the same problems across all of their games, namely the memory leaks which leads to a lot of the crashing, long load times, hung up loads, framerate, etc.

  • I sorta would say Fallout 4. Except it wasn't so much the technical issues as in bugs, it was that the game didn't really look much better than Fallout 3 and New Vegas, and I just didn't have it in me to keep overlooking that issue.
    Though I might have given it more time if it hadn't been for some crashing and glitches.

  • Although it was the dark horse in the series, I still had a kick playing Resistance 2. The online multiplayer was interesting and I was quite a fan of RFoM MP and I was just starting to get into the changes of R2 MP, and after a day or 2 it just didn't work for me no matter what.

    It worked for all of my friends but it absolutely would not work for me.

  • More interested in the save game issue: Is it a common problem or does it might have to do with some cloud saves? For me it was No Man Sky. After I’ve done everything except traveling to the centre of the universe I had the common bug that multiple warping crashes the game. And due to how NMS handles saving I had enough (for now).

  • @Ikataishou I've never had a save issue with a Bethesda game. I've occasionally confused myself and loaded the wrong save, of course. And the survival mode restricts you to three autosaves, but those never fail unless you delete or save over them.

  • Global Moderator

    I had the "when savefile reaches a certain size it freezes when you touch water" bug in Skyrim, but that didnt stop me from playing once I found a way around it.

    A game that stoped me from playing were Need For Speed: Most Wanted to PS2. I had played this for hours and hours, almost got every car from the blacklist people. Had a lot of money and reputation, coming home from school one day "to finish up" and just meets of "memory card corrupted". I have never finished this game, I never will.

  • @ZyloWolfBane falout 4 was my first real problem with bethesda. I don't know how common it is but I played through pretty much a of falout 3 and oblivion multiple ties without anything totally game breaking. Fallout 4 was going wel too except for this problem. Really is a bummer that they just can't seem to get it together on the technical side

  • @Ikataishou its really weird. I'll go to the directory and there are save files from when I had been playing but theres no data. So it'll say Fallout409/12/16.....0kb. And the save below that it loaded me into was around 22,000 kb. So it seems like it was saving during my previous play session but not actually recording the data. It did aso delete a bunch of saves btw the 0kb and 22,000 kb saves fro other sessions though. Its weird and really frustrating. Cloud might have something to do with it, I wonder if my computer turned off during the sync and that messed it up but I really don't know :/

  • @Lotias NOOOO memory corruption is the worst, at least I could go back to an earlier save. Sorry to hear that

  • @Lotias How did that happen exactly? I completed basically everything in the game and DLC on one character, as well as having other saves on the 360 hard drive, and I never experienced that.

  • Global Moderator

    @crustef Yeah it was really sad! really put me off finishing it, I have played it a few hours here and there with friends later on, but never gotten very far.

    @Haru17 I believe that it had to be an quite exact number on the savefile, it also got patched eventually. I played skyrim on PS3 as well, not xbox haha

  • @Haru17 Ok, I was just referring to the OP ^^. I’ve only had problems with saves from Bethesda with a heavily modded Skyrim, like to much blood textures :).

    @crustef That is really strange. On PC and with Steam it might have tried to replace the deleated data and failed. Might try to disable cloud save. But there could be a lot of reasons for this... . Maybe antivirus software or change to admin rights for fallout 4?

  • Not the game's fault. But I had a used copy of Shenmue II for xbox and lost and hour of unsaved gameplay due a disc error. Because of the slow pacing of Shenmue games, I was never motivated to replay that part.

    The reason I end up never finishing a game is because I may step away from them too long. And trying to pick up where I left off just feels wrong when you forget the entire story and context of your continuation point. So I feel compelled to have to start over. I've done this with GTA Vice City multiple times, Zelda Twilight Princess, God of War, and many others. I really appreciate when a game gives a little summary of where you last left off. The Arkham games do a great job with that.

    While on the topic of Arkham, though I didn't quit, that tank in Arkham Knight made me come close. I'm not much of a dual analog shooter. So I was in quite a rage if I was having trouble on tank missions. I would scream and cuss "Why the @#$&^ does Batman need a tank!?"

  • Just Cause 3 on PS4. So to preface this I played the game at EGX and it ran smoothly. I thought to myself, cool seems fun, maybe I will pick it up. (I actually won the game there but through a series of mistakes and travelling, they never sent it to me)

    Any how fast forward to February, when I repurchased a PS4 and Just Cause 3 came with it. After I completed the games I missed out in that I really wanted to finish (Bloodborne dlc, Life is Strange Episode 5) I turned my attention to JC3.

    After a few hours of play I was generally having fun, more fun than I ever did with JC2 but technically the game ran like a mess. I remember making my way to this huge base and after firing off one rocket the frame rate appeared to just half and go into the teens. That's when I decided no, this is enough for me.

    The whole point of the game is to blow things up and as soon as you do that it just goes to complete crap.

  • Second Sight on Gamecube, dunno how far exactly I was but eventually a cutscene won't load, or better said, only the sound but with a black screen, and after the sound ended nothing else happened, reloading didn't help either. And not knowing if that was a savestate issue or a disk issue I never played it again.

  • Master Chief Collection :'(

  • A ton of them.

    My biggest pet peeves are:
    Bad controls
    Severe FPS issues
    Game breaking bugs

    Poor game design is also up there, but it's not really tied to the technical aspects.

    As for game examples then...
    Witcher 1 at release was a huge mess, I had to wait for the big patch that came 1 year after release to actually finish the game. The bugged quests, messed up dialogue, wonky gameplay, 1min loading times (even when entering small houses, which was infuriating during the part where you randomly got kicked out of a house by an old lady at Shani's residence, forcing you to sit through like 5-6 min worth of loading screens to progress the story).

    Skyrim at release. Too much stuff to even list. It was made even worse since I tried to play it on my laptop (which had above recommended hardware). I still to this day haven't finished that game despite all the praise.

    Metro 2033 Where to start? Broken AI, bugs galore, wonky button inputs (I really loved sneaking up on someone having them within takedown range only for them to slightly move out of range making the takedown turn into a whiffed knife attack that somehow was loud as fuck and triggered all the nearby guards into alert mode) and more.

  • For what it's worth, I've never quit a game due to technical issues. Not even when I've lost progress, though I've never had that happen to me in the middle of a playthrough non-voluntarily.

    I also play most games on Nintendo and Playstation platforms, so there's a good bit less of a risk factor overall.

  • I wouldn't say I was really digging it before the technical issues started (after all, they began with a hard crash in the first five minutes of the game) but I was trying to play Just Cause 3 back around February or so on PS4. It was okay but after a certain point it got an update and for some reason that update made the game look like I was playing it on a toaster PC from 2004 on minimum settings, and it made the framerate worse as well in some spots. After an hour I realized this game wasn't worth suffering through if that's going to happen and just gave up entirely.