Bug Reports



  • @Claus-Grimhildyr Test.



  • I'm having a very difficult time with cookies on the Easy Allies Forums. For some reason, Firefox keeps blocking my forum cookies here. I only discover this after browsing the forums for a little bit and something no longer works or I get an error telling me my session is invalid. At that point I click the padlock in the address bar and see that cookies have been blocked. From that popup I am able to instruct Firefox to allow cookies and then it works for a little bit after refreshing the page until it decides to stop working again.

    I've made an exception for easyallies.com and forums.easyallies.com in my browser's cookie settings to "always allow", but it doesn't help.


  • admin

    @Chocobop not sure why you're having issues. There doesn't seem to be anything we can do on our end, but here are Mozilla's troubleshooting steps.
    https://support.mozilla.org/en-US/kb/websites-say-cookies-are-blocked-unblock-them


  • Global Moderator

    @Chocobop that happens to me on very rare occasions, but it always works after a page reload



  • Possible bug? When you go into your profile settings, you can check a setting that says "paginate topics and posts instead of infinite scroll". Below this it lets you choose how many topics and posts appear per page.

    The bug is that it doesn't seem to save your changes. I've tried changing some of these values to 30 and 40 to no avail.



  • The mobile site on Chrome seems to be borked for me. Font size is really small, some graphics are missing, and the menu button is aligned to the top center of the page instead of the top right. Don't know if anyone else is experiencing the same problem. Works fine in mobile Firefox.



  • @Gaming_Groove Just checked there on my phone and it seems to be fine. Wonder if anyone else has similar issues?

    Did chrome update recently?



  • @tokeeffe9 actually, I'm on the sandstone theme... Switching it back to default seems to fix it. Don't know if it is a problem with just that theme...



  • The tablet and on pc (chrome), the website is also borked for me. It works fine on mobile.



  • Changing the theme seems to work but it only affected superhero for me. I think it affects the theme that you use frequently.



  • Same thing happening on firefox. Picture for reference:

    alt text



  • yeah I'm getting the same formatting issue on Firefox.



  • @DeweyDTruman It's the Superhero theme you're using. Something in it is broken. Try any other theme, you'll be fine.



  • @Chocobop I narrowed down my problem (and hopefully have a solution)

    My cookies weren't being blocked completely at random, the pattern turned out to be that Firefox would block my "forums.easyallies cookies" (i.e. my login cookie) whenever I loaded a thread that contained a twitter link. The way this forum's software works, typing a comment with a twitter link automagically get expanded into a nicer "twitter embed/preview" instead of a plain URL when that comment gets posted.

    This causes an interaction with a privacy add-on I had installed: Priv3. It is supposed to block twitter from using cookies to track my browsing history (unless I explicitly interact with the twitter embed), but for who knows whatever reasons the plugin just blocks ALL cookies on the entire page and thus really borks my forum login.

    The solution was to uninstall it and use the "successor plugin" called Priv3+. Initial testing shows that when I load a thread with a twitter embed I still maintain my login. Now I can finally read the "That's News" thread (which rarely has a page without a twitter link ;) ) without everything going haywire and having to go through multiple cycles of "unblock cookies / login / logout "



  • @Sazime It's doing it on every theme now (except Default and I think Readable). I don't think it has anything to do with any plugins I'm using since I disabled everything and updated my browser but it kept happening.



  • @DeweyDTruman Oh wow, you're right. It doesn't effect Darkly (for me, it's what I've been using for a while), but everything else other than that, Default and Readable is a mess in the "header-menu" is completely messed up.

    How are Darkly, Readable and the Default for you?



  • @Sazime Darkly's a mess too, Readable and Paper seem to be working fine though.



  • @DeweyDTruman And whiule I was trying to find the problem myself, I made it happen in Darkly as well. Yeah, this is a weird issue.



  • @DeweyDTruman There's a problem in the "bootstrap.mini.css" file, at the very least


  • Global Moderator

    Now things have started to go wrong on my side as well, and I've tried to change theme, clear cookies etc, nothing helps